Just bought a 95 Polaris Indy 500 EFI - Snowmobile Forum: Your #1 Snowmobile Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 08-22-2012, 02:30 PM Thread Starter
Registered User
 
FLASH1970's Avatar
 
Join Date: Mar 2008
Location: Lake Geneva WI
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Just bought a 95 Polaris Indy 500 EFI

This was my grandpas sled. He always joked around about putting remote start on it so I might do it for kicks. I was told it had a problem staying running when you tried to move but idled fine. So I got it home, checked fluids, started it up with starter fluid, then it'd die after 10 seconds. I disconnected the fuel line, no fuel coming out. So I hit it with some compressed air, freed up the fuel line, reconnected everything and it ran fine. I took around the yard. Then I had a problem for a couple minutes where it wouldn't go over 4k rpm. But I shut it down, restarted it and it ran ok again. I plan to replace the fuel filter and clean out the injectors among other things.

06 Fusion 900- HTG 975, HTG ceramic pipe & can, V Force 3's, gutted airbox, 136" Mountain Machines rail extensions, Fabcraft 8" wheels, SLP tunnel extension, 1.25 Ripsaw studded, left hand throttle added, Dual KOSO EGT's, Boondocker fuel controller, 2008 spindles, Boondocker Synergy kit, KOSO Wideband, 2" riser.

95 Indy 500 EFI- Ummmm, stock.
FLASH1970 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 08-22-2012, 02:38 PM Thread Starter
Registered User
 
FLASH1970's Avatar
 
Join Date: Mar 2008
Location: Lake Geneva WI
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Here are some pics.
Attached Thumbnails
Click image for larger version

Name:	2012-08-11 12.01.03.jpg
Views:	4033
Size:	102.1 KB
ID:	19301   Click image for larger version

Name:	2012-08-11 11.58.54.jpg
Views:	1410
Size:	95.8 KB
ID:	19302   Click image for larger version

Name:	2012-08-11 11.56.39.jpg
Views:	3054
Size:	102.7 KB
ID:	19303   Click image for larger version

Name:	2012-08-11 11.59.39.jpg
Views:	2107
Size:	97.5 KB
ID:	19304   Click image for larger version

Name:	2012-08-11 11.56.26.jpg
Views:	601
Size:	72.6 KB
ID:	19305  


06 Fusion 900- HTG 975, HTG ceramic pipe & can, V Force 3's, gutted airbox, 136" Mountain Machines rail extensions, Fabcraft 8" wheels, SLP tunnel extension, 1.25 Ripsaw studded, left hand throttle added, Dual KOSO EGT's, Boondocker fuel controller, 2008 spindles, Boondocker Synergy kit, KOSO Wideband, 2" riser.

95 Indy 500 EFI- Ummmm, stock.
FLASH1970 is offline  
post #3 of 6 (permalink) Old 08-22-2012, 04:00 PM
ride till your broke
 
Renagade's Avatar
 
Join Date: Dec 2010
Location: Northern Illinois
Posts: 2,560
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
nice sled!!!
i would check fuel pump pressure & compression.
does it rev past 4k on a stand? could be
a weak secondary spring? bad belt?
winters comming!!!!

------------------
current sleds
04 rev800ho gade
95 formulaIII 600
77 olympic 340e
ummm.... I could live in my sled trailer if i had to!!
Renagade is offline  
post #4 of 6 (permalink) Old 08-22-2012, 04:36 PM Thread Starter
Registered User
 
FLASH1970's Avatar
 
Join Date: Mar 2008
Location: Lake Geneva WI
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Not sure if it revs past 4k on a stand. After a couple minutes of sitting I started it back up and it was fine. The sled hadn't been run in 2 years and I think the newest trail sticker on it is from 02... So I'll go through it all.

06 Fusion 900- HTG 975, HTG ceramic pipe & can, V Force 3's, gutted airbox, 136" Mountain Machines rail extensions, Fabcraft 8" wheels, SLP tunnel extension, 1.25 Ripsaw studded, left hand throttle added, Dual KOSO EGT's, Boondocker fuel controller, 2008 spindles, Boondocker Synergy kit, KOSO Wideband, 2" riser.

95 Indy 500 EFI- Ummmm, stock.
FLASH1970 is offline  
post #5 of 6 (permalink) Old 08-22-2012, 06:17 PM
Registered User
 
dhridenh's Avatar
 
Join Date: Jun 2012
Location: New Hampshire
Posts: 614
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
my sled in my avitar looked the same as that sled its a 94 and mine is a sks but its a awsome sled u have the same problem with your top air filter that i had but i was able to fix the filter with out buying a new one i bot a shop vac air filter its the same stuff in the center then i removed both the rings from the filter cut the new media and then glued them together there a pic of it and look at my pics my girl thought your pic of your sled was my sled hahahaha
Attached Thumbnails
Click image for larger version

Name:	0821121118.jpg
Views:	428
Size:	40.3 KB
ID:	19306  

94 polaris Indy 500 EFI SKS Snow King Special l/c and 95 polaris Indy Trail 500 f/c ooo yea love polaris BRAAAAPP
dhridenh is offline  
post #6 of 6 (permalink) Old 08-22-2012, 06:19 PM
Registered User
 
dhridenh's Avatar
 
Join Date: Jun 2012
Location: New Hampshire
Posts: 614
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
http://www.snowmobileforum.com/gener...9-paint-2.html this is the paint i did on it to get ride of the color that was on it i think it looks good

94 polaris Indy 500 EFI SKS Snow King Special l/c and 95 polaris Indy Trail 500 f/c ooo yea love polaris BRAAAAPP
dhridenh is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile Forum: Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome