2010 Polaris assault 120cc revving - Snowmobile Forum: Your #1 Snowmobile Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 12-03-2011, 08:18 PM Thread Starter
Registered User
Join Date: Dec 2011
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2010 Polaris assault 120cc revving

Just bought a 2010 Assault mini 120 for my kids. When started and warmed up the engine revs/cycles. When I push the thumb throttle in the most low throttle setting the revving goes away and the engine runs fine. I also learned that when I disconnect what I think is the rpm limiter the engine runs fine at an idle and does rev as normal with advancing the throttle.. Is the rev limiter bad or is there something else I'm missing....thanks!
Slabonte is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Snowmobile Forum: Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome