96 xcr 600 sp HELP IS BADLY NEEDED! - Snowmobile Forum: Your #1 Snowmobile Forum
http://www.snowmobileforum.com
Go Back   Snowmobile Forum: Your #1 Snowmobile Forum > Specific Snowmobile Forums > Polaris Snowmobiles


» Sponsors





Reply
 
LinkBack Thread Tools Display Modes
Old 01-11-2011, 08:50 PM   #1 (permalink)
Registered User
 
RacerX125us's Avatar
 
Join Date: Dec 2009
Location: Bay City
Posts: 4
96 xcr 600 sp HELP IS BADLY NEEDED!

i have a 96 xcr 600 sp. i also have tunnel protectors however for whatever reason i don't know my studs are ripping out the inside of my tunnel. i don't know if my studs are too long or if my track is too loose. i've been told either way. it only happens on hard acceleration and not on braking. wtf? i've tightened the track to what the local polaris dealer told me and it still sounds like it's gonna rip my rear off if i don't get it fixed please help!
__________________
If it ain't fast, it ain't worth having.

Last edited by BC_Dan; 01-12-2011 at 10:13 AM. Reason: profanity
RacerX125us is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-12-2011, 04:38 AM   #2 (permalink)
Registered User
 
Join Date: Feb 2009
Location: Pa.
Posts: 240
What size lug on track and what size stud are you running?
__________________
2003 Yamaha RX-1 1000
2000 Polaris 700 XC 45th Anniversary Edition
1997 Polaris Indy 500 Sport
1998 Polaris Indy 500
1996 A Cat panther dlx 440
kikkinurazz3 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 10:45 PM.



Copyright SnowmobileForum.com

Search Engine Friendly URLs by vBSEO 3.6.0