Polaris Rush Broke - Snowmobile Forum: Your #1 Snowmobile Forum
http://www.snowmobileforum.com
Go Back   Snowmobile Forum: Your #1 Snowmobile Forum > Specific Snowmobile Forums > Polaris Snowmobiles


» Sponsors





Reply
 
LinkBack Thread Tools Display Modes
Old 02-10-2010, 06:29 PM   #1 (permalink)
Registered User
 
Join Date: Jan 2010
Posts: 9
Polaris Rush Broke

Well i was up to tug hill riding sat and almost didnt make it back to camp. sled has about 230 miles on it and i think some major stuff broke in the chain case, started out sounding like the chain sliping like a motorcycle would do if the sprocket was worn down. so out on the trail we tightened the chain but had to go in alot. headed back to camp and it started to do it worse, almost didnt make it and when loading it on the trailer it prety much wouldnt move.
Had a buddy of mine drop it off late last nite so i know its gonna be a few days for them to get to it.
I dont like when they told my friend they would call to let me know whats wrong and if i want to fix it. Pretty much the onlyu reason i took it to a dealer is that it should be covered under some sort of warrenty i would assume. ive only had it 2 months and it only has about 230 miles so i guess it better be covered.
when i get the results ill update on here. crappy part is we are getting snow and i could be riding around my house instead of traveling 3 hrs north
mxracer111 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-10-2010, 06:35 PM   #2 (permalink)
Registered User
 
AC Rider's Avatar
 
Join Date: Oct 2008
Location: Michigan
Posts: 4,571
that sucks man! Let us kno whats wrong with it! Before you had that issue, were u happy with the sled? ive heard mixed reviews on the Rush and im curious
__________________
10/11 season: 1014 miles
My sled:
03 z440 sno pro w/ 3000 miles
-Fresh Top End
-Rejetted
-white handguards
-4 inch riser
-1.375 inch track




rest of the fleet:
2003 polaris classic 340 3000 miles(FS)-2003 polaris indy xc 500 2200 miles(FS)-2000 polaris xc 700 7000 miles-2003 arctic cat zl 600 3200 miles-1999 arctic cat zl500 4500 milesSOLD
AC Rider is offline   Reply With Quote
Old 02-10-2010, 07:18 PM   #3 (permalink)
Registered User
 
Join Date: Jan 2010
Posts: 9
its been 10 yrs sence i had a sled so hard to compare to other models but as a motocross raceer i love it, plenty of power for me, tops out about 82 or so but in the woods its a blast. you deff. need to remember to lean into it when turning, i havent had much time to make any adj to it maybe next year ill have more time to ride.
mxracer111 is offline   Reply With Quote
Old 02-10-2010, 07:24 PM   #4 (permalink)
Registered User
 
snownstunt600's Avatar
 
Join Date: Jan 2010
Location: SE Minnesota
Posts: 1,376
it really only does like 80??
snownstunt600 is offline   Reply With Quote
Old 02-12-2010, 06:53 PM   #5 (permalink)
Registered User
 
Join Date: Jan 2010
Posts: 9
Sled is all fixed

Dealership called and said sled was ready. went up to talk with them and they said i was good to go all under warrenty.
The chain case cover o-ring from the factory when it was installed was pinched, it allowed just a tiny bit of oil to come out and wasnt noticeable untill they took it apart. it ran low on oil and caused the chain to become hot which melted the plastic piece in side for the adj. they gave it new chain, 2 gears and o-ring, fresh oil and sent me on my way. hope the pics attach to show what happened.

As far as i know it dosent get much past 82-85 going accross lake but gets there very quick, in a drag i beat 800's and 1000's till about 72 then they started to pass and walk away from me. as for mid 80's being top speed im happy with that, i dont do much lake riding and i can keep up with or stay in front of any sled out there in the trails and woods pretty much. guess im getting old, tripple didgets dont excite me like they used to lol
Attached Thumbnails
Polaris Rush Broke-img_8486.jpg   Polaris Rush Broke-img_8487.jpg   Polaris Rush Broke-img_8490.jpg  
mxracer111 is offline   Reply With Quote
Old 02-12-2010, 07:30 PM   #6 (permalink)
Registered User
 
MAAHS13's Avatar
 
Join Date: Nov 2009
Location: Sault Ste. Marie, ON
Posts: 152
thats what polaris came out with the pro r 800 on the rush chassis for those who want the speed
MAAHS13 is offline   Reply With Quote
Old 02-12-2010, 08:14 PM   #7 (permalink)
TRH- Troll Raising Hell
 
JheLrey's Avatar
 
Join Date: Mar 2007
Location: Medina, MN
Posts: 6,115
Glad they took care of you!
JheLrey is offline   Reply With Quote
Old 02-12-2010, 08:28 PM   #8 (permalink)
josh
 
xc sp 500 rider's Avatar
 
Join Date: May 2009
Location: mn
Posts: 2,034
really only 80mph! ive got 95 on my 500 and it still had throttle left!
__________________
Can it! Then you'll at least sound like your keeping up!
xc sp 500 rider is offline   Reply With Quote
Old 02-12-2010, 08:36 PM   #9 (permalink)
---------(PI488)---------
 
polarisindy488's Avatar
 
Join Date: Jan 2010
Location: New Hampshire
Posts: 2,736
i did 80mph on an ice track with my98 polaris 488 the pic is my avatar
__________________






SLED'S
-2009 YAMAHA PHAZER GT-red,with red shock covers,96 picks and Retrax wheels
-1998 POLARIS INDY ss 488 Power Madd hand guards,chrome power Madd windsheild,
2 inch risers,black KIMPEX Dullies ski's with blue loops,1.25 lug track with 96 pics and a black light cover
Quad's
-03 yamaha BearTracker 250
-05 yamaha Raptor 350
10/11 miles: 1140
polarisindy488 is offline   Reply With Quote
Old 02-12-2010, 09:58 PM   #10 (permalink)
Trevor
 
YamahaSS440's Avatar
 
Join Date: Apr 2009
Location: Wisconsin
Posts: 4,126
The speedo said that, get a gps to get a more accurate reading. Wow that chain definately got hot!
__________________
2009/2010 Miles:900
2010/2011 Miles:1300
2011/2012 Miles:530
2012/2013 Miles:1050
YamahaSS440 is offline   Reply With Quote
Old 02-13-2010, 07:51 AM   #11 (permalink)
---------(PI488)---------
 
polarisindy488's Avatar
 
Join Date: Jan 2010
Location: New Hampshire
Posts: 2,736
ya i was thinkin that when i got out the thee race track
__________________






SLED'S
-2009 YAMAHA PHAZER GT-red,with red shock covers,96 picks and Retrax wheels
-1998 POLARIS INDY ss 488 Power Madd hand guards,chrome power Madd windsheild,
2 inch risers,black KIMPEX Dullies ski's with blue loops,1.25 lug track with 96 pics and a black light cover
Quad's
-03 yamaha BearTracker 250
-05 yamaha Raptor 350
10/11 miles: 1140
polarisindy488 is offline   Reply With Quote
Old 02-13-2010, 09:14 AM   #12 (permalink)
Registered User
 
Polaris87's Avatar
 
Join Date: Jan 2004
Location: PE Canada
Posts: 466
Who cares how fast you went! That Rush would run all over our 500 Indy's....Who needs to go 100mph when you have that suspension!
__________________

540 Open Mod
1995 Polaris Indy 500

White EPI primary spring with 10 weights
Purple EPI secondary spring, 45/36 HRP helix
Polaris87 is offline   Reply With Quote
Old 02-13-2010, 09:15 AM   #13 (permalink)
Trevor
 
YamahaSS440's Avatar
 
Join Date: Apr 2009
Location: Wisconsin
Posts: 4,126
Haha yea!
__________________
2009/2010 Miles:900
2010/2011 Miles:1300
2011/2012 Miles:530
2012/2013 Miles:1050
YamahaSS440 is offline   Reply With Quote
Old 02-13-2010, 12:33 PM   #14 (permalink)
Super Moderator
 
BC_Dan's Avatar
 
Join Date: Jan 2004
Location: oregon
Posts: 12,526
Glad to hear that the dealer took care of you! I have yet to see a Rush out west, they didn't sell many of 'em here... would be fun to give one a try!
__________________
2007 Dragon RMK 700 155", 2008 RMK 600 155", 95 Prowler 550 2-up, Really OLD AC Cheetah

http://www.avalanche.org/accidents.php
BC_Dan is offline   Reply With Quote
Old 02-13-2010, 06:22 PM   #15 (permalink)
Registered User
 
Join Date: Feb 2009
Posts: 15
Quote:
Originally Posted by xc sp 500 rider View Post
really only 80mph! ive got 95 on my 500 and it still had throttle left!
You do not have 95 on your 500 with throttle left no way.
ads221430 is offline   Reply With Quote
Old 02-13-2010, 11:42 PM   #16 (permalink)
Registered User
 
Polaris87's Avatar
 
Join Date: Jan 2004
Location: PE Canada
Posts: 466
hahahahah thats what im sayin.... I have my 95 500 working pretty good...Its clutched and I can get 80. 85 if I hold it to the point where its revving that long that It sounds like the motor is going to vibrate out of the mounts and come through the engine bonnet...The motors got 75 horse...the rush has 123. So give it up...
__________________

540 Open Mod
1995 Polaris Indy 500

White EPI primary spring with 10 weights
Purple EPI secondary spring, 45/36 HRP helix
Polaris87 is offline   Reply With Quote
Old 02-14-2010, 05:20 AM   #17 (permalink)
Registered User
 
Join Date: Jan 2009
Posts: 21
thats exactly what happened to me 2 weeks ago except I dont have a brand new rush lol.
01polaris550 is offline   Reply With Quote
Old 03-01-2010, 01:15 PM   #18 (permalink)
Registered User
 
manzo70's Avatar
 
Join Date: Feb 2010
Location: Whitby, ON
Posts: 27
Quote:
Originally Posted by ads221430 View Post
You do not have 95 on your 500 with throttle left no way.
I had an '01 XCSP 500 2 years ago, and believe me, they are 100 mph sleds.
manzo70 is offline   Reply With Quote
Old 03-02-2010, 10:16 AM   #19 (permalink)
Registered User
 
Polaris87's Avatar
 
Join Date: Jan 2004
Location: PE Canada
Posts: 466
yea and the 01 xcsp also have exhaust valve liberty engines. Your talking now over 100 horse. Not a 95 fugi with 75.
__________________

540 Open Mod
1995 Polaris Indy 500

White EPI primary spring with 10 weights
Purple EPI secondary spring, 45/36 HRP helix
Polaris87 is offline   Reply With Quote
Old 03-02-2010, 06:48 PM   #20 (permalink)
Registered User
 
manzo70's Avatar
 
Join Date: Feb 2010
Location: Whitby, ON
Posts: 27
Quote:
Originally Posted by Polaris87 View Post
yea and the 01 xcsp also have exhaust valve liberty engines. Your talking now over 100 horse. Not a 95 fugi with 75.
I wasn't referring to a 95 500 fugi, someone denied a '01 xcsp 500 being able to do over 95mph
manzo70 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 10:40 PM.



Copyright SnowmobileForum.com

Search Engine Friendly URLs by vBSEO 3.6.0