polaris 120 breaking chain - Snowmobile Forum: Your #1 Snowmobile Forum
http://www.snowmobileforum.com
Go Back   Snowmobile Forum: Your #1 Snowmobile Forum > Specific Snowmobile Forums > Polaris Snowmobiles


» Sponsors





Reply
 
LinkBack Thread Tools Display Modes
Old 01-11-2010, 02:24 PM   #1 (permalink)
Registered User
 
Join Date: Jan 2010
Posts: 1
polaris 120 breaking chain

Hello, I'm looking for any information or if anyone else has encountered any problems with their xcr 120 breaking the chain, this happens constantly at the master link, we get about 1-2 hours of use with each master link. Any suggestions?
polaris j is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-17-2011, 11:12 AM   #2 (permalink)
Registered User
 
Join Date: Jan 2011
Posts: 1
Had the same issue with my daughter's Polaris 120 yesterday.

Put a new masterlink on and noticed than when turning the track the masterlink link would sometimes get caught up in the driven clutch as the "plate" and masterlink clip sticks out more than the other links.

I took the masterlink off and put it on "backwards" so the plate and masterlink clip was facing the engine. No more binding when spining by hand.

She rode it around for an hour or so yesterday afternoon and so far so good.

Please post back and let me know if this helped.
dcstewart77 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 08:44 AM.



Copyright SnowmobileForum.com

Search Engine Friendly URLs by vBSEO 3.6.0