polaris indy idling too high? - Snowmobile Forum: Your #1 Snowmobile Forum
http://www.snowmobileforum.com
Go Back   Snowmobile Forum: Your #1 Snowmobile Forum > Specific Snowmobile Forums > Polaris Snowmobiles


» Sponsors





Reply
 
LinkBack Thread Tools Display Modes
Old 12-28-2008, 07:29 PM   #1 (permalink)
X-tra L-ettuce & T-omato
 
polaris_olezy's Avatar
 
Join Date: Dec 2008
Location: Thunder Bay, Ontario
Posts: 161
polaris indy idling too high?

hey guys! well i got my last problem fixed and a new one arrised!
when i have let my sled idle it idles too high? like at the 4000 on the rpm gauge? it normally runs at 2000, but with a flick of the choke it idles back down to 2000, maby its a problem with the choke plunger? otherwise my sleds running good i just need to flick the choke every once in awhile when im idling it.
polaris_olezy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-28-2008, 07:31 PM   #2 (permalink)
X-tra L-ettuce & T-omato
 
polaris_olezy's Avatar
 
Join Date: Dec 2008
Location: Thunder Bay, Ontario
Posts: 161
oh and i forgot my sleds a 93 polaris indy sks
polaris_olezy is offline   Reply With Quote
Old 12-28-2008, 07:49 PM   #3 (permalink)
Registered User
 
Tdiguy69's Avatar
 
Join Date: Nov 2008
Location: Huron Park, Ontario
Posts: 82
Mines doing that some times to ill stop and it will hang at 4000 rpm....i was told that its usally a crank seal leak...so try spraying wd 40 around the block and if the rpm goes up your cranks leaking
__________________
1995 Polaris XCR 600
Plastic skis (purple)
Belly pan protector
Fox shocks all around
Heated grips and visor
Studded
Sportech headlight and tail light covers (purple)
Cobra windsheild (white with checkers)
Windsheild bag (purple)
Runing board trim (purple)
DG Silencer can
2 inch bar riser
Tdiguy69 is offline   Reply With Quote
Old 12-28-2008, 07:56 PM   #4 (permalink)
X-tra L-ettuce & T-omato
 
polaris_olezy's Avatar
 
Join Date: Dec 2008
Location: Thunder Bay, Ontario
Posts: 161
thanks tdiguy! ill giver a try one more question how much does a crank seal run for!?
polaris_olezy is offline   Reply With Quote
Old 12-28-2008, 07:58 PM   #5 (permalink)
Registered User
 
Tdiguy69's Avatar
 
Join Date: Nov 2008
Location: Huron Park, Ontario
Posts: 82
Im not to sure how much it is for the seal...im guessing not alot but your going to have to pull the motor out to replace it thats the problem. Also check your carb boots i found mine are weather cracked and im replacing them and all fuel lines for cracks to.
__________________
1995 Polaris XCR 600
Plastic skis (purple)
Belly pan protector
Fox shocks all around
Heated grips and visor
Studded
Sportech headlight and tail light covers (purple)
Cobra windsheild (white with checkers)
Windsheild bag (purple)
Runing board trim (purple)
DG Silencer can
2 inch bar riser
Tdiguy69 is offline   Reply With Quote
Old 12-28-2008, 08:02 PM   #6 (permalink)
X-tra L-ettuce & T-omato
 
polaris_olezy's Avatar
 
Join Date: Dec 2008
Location: Thunder Bay, Ontario
Posts: 161
i took my carbs out 2 nites ago thier fine, the previous owner said it did this and i didnt think anything of it? its running great still but it just wants to idle at 4k on the rpm meter haha, oh and it stopped doing this when i changed the plugs to champion and now that im back to NGK it just started?!
polaris_olezy is offline   Reply With Quote
Old 12-28-2008, 08:06 PM   #7 (permalink)
Registered User
 
Tdiguy69's Avatar
 
Join Date: Nov 2008
Location: Huron Park, Ontario
Posts: 82
Weird mine started doing this also when i put new plugs in that were ngks also....what ones you put in 8s or 9s
__________________
1995 Polaris XCR 600
Plastic skis (purple)
Belly pan protector
Fox shocks all around
Heated grips and visor
Studded
Sportech headlight and tail light covers (purple)
Cobra windsheild (white with checkers)
Windsheild bag (purple)
Runing board trim (purple)
DG Silencer can
2 inch bar riser
Tdiguy69 is offline   Reply With Quote
Old 12-28-2008, 08:09 PM   #8 (permalink)
X-tra L-ettuce & T-omato
 
polaris_olezy's Avatar
 
Join Date: Dec 2008
Location: Thunder Bay, Ontario
Posts: 161
i put 8's in the last owner had 9's and he was fouling them by the dozen!
polaris_olezy is offline   Reply With Quote
Old 12-28-2008, 08:13 PM   #9 (permalink)
Registered User
 
Tdiguy69's Avatar
 
Join Date: Nov 2008
Location: Huron Park, Ontario
Posts: 82
mine had 8s. If you want good plugs try BR9EYA or 8s there designed to not foul as easy.
__________________
1995 Polaris XCR 600
Plastic skis (purple)
Belly pan protector
Fox shocks all around
Heated grips and visor
Studded
Sportech headlight and tail light covers (purple)
Cobra windsheild (white with checkers)
Windsheild bag (purple)
Runing board trim (purple)
DG Silencer can
2 inch bar riser
Tdiguy69 is offline   Reply With Quote
Old 12-28-2008, 08:15 PM   #10 (permalink)
X-tra L-ettuce & T-omato
 
polaris_olezy's Avatar
 
Join Date: Dec 2008
Location: Thunder Bay, Ontario
Posts: 161
well than thier doing the trick haha, these plugs are damn good! the champions i had gave me some trouble after the first day i had them, they were all black and nasty looking!
polaris_olezy is offline   Reply With Quote
Old 12-28-2008, 08:18 PM   #11 (permalink)
Registered User
 
Tdiguy69's Avatar
 
Join Date: Nov 2008
Location: Huron Park, Ontario
Posts: 82
Okay if you have more problems check your plug caps to. I just had a spark plug cap go bad i hit a drift and snow came in through the screen and made the sled run on 2 cyclinders. I added some dielectric grease to all my caps to increase water resistance.
__________________
1995 Polaris XCR 600
Plastic skis (purple)
Belly pan protector
Fox shocks all around
Heated grips and visor
Studded
Sportech headlight and tail light covers (purple)
Cobra windsheild (white with checkers)
Windsheild bag (purple)
Runing board trim (purple)
DG Silencer can
2 inch bar riser
Tdiguy69 is offline   Reply With Quote
Old 12-28-2008, 08:20 PM   #12 (permalink)
X-tra L-ettuce & T-omato
 
polaris_olezy's Avatar
 
Join Date: Dec 2008
Location: Thunder Bay, Ontario
Posts: 161
ok thanks tdiguy, needed the help haha!
polaris_olezy is offline   Reply With Quote
Old 12-28-2008, 08:21 PM   #13 (permalink)
Registered User
 
Tdiguy69's Avatar
 
Join Date: Nov 2008
Location: Huron Park, Ontario
Posts: 82
Best of luck....let me know if your cranks leaking.
__________________
1995 Polaris XCR 600
Plastic skis (purple)
Belly pan protector
Fox shocks all around
Heated grips and visor
Studded
Sportech headlight and tail light covers (purple)
Cobra windsheild (white with checkers)
Windsheild bag (purple)
Runing board trim (purple)
DG Silencer can
2 inch bar riser
Tdiguy69 is offline   Reply With Quote
Old 12-28-2008, 08:27 PM   #14 (permalink)
X-tra L-ettuce & T-omato
 
polaris_olezy's Avatar
 
Join Date: Dec 2008
Location: Thunder Bay, Ontario
Posts: 161
ill need it! but i will remember to get back to you about the crank seal im not near my sled rite now but i will be in a bit, thanks alot man!!!!!
polaris_olezy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 03:39 PM.



Copyright SnowmobileForum.com

Search Engine Friendly URLs by vBSEO 3.6.0