86 excel issues - Snowmobile Forum: Your #1 Snowmobile Forum
http://www.snowmobileforum.com
Go Back   Snowmobile Forum: Your #1 Snowmobile Forum > General Discussion Forums > General Sled Chat


» Sponsors





Reply
 
LinkBack Thread Tools Display Modes
Old 02-03-2013, 07:46 PM   #1 (permalink)
Registered User
 
ARCHER97's Avatar
 
Join Date: Nov 2011
Location: Milan, Mi
Posts: 223
86 excel issues

Ok, my 340 excel has no pep! It runs, has good power and idles fine but when you hit the throttle it takes a second to react. The clutches are clean and working good. However, there is a crack in the exhaust before the expansion chamber and its running fairly rich on oil. Could any of these be causing this?
__________________
'80 Yamaha 440 Exciter

'79 Yamaha 340 Enticer with
'78 txl 340 motor and a '80s
Indy skid.

'95 Polaris XCR 600

'86 Yamaha excel IIIU
ARCHER97 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-04-2013, 04:42 AM   #2 (permalink)
Super Moderator
 
RJ Gleason's Avatar
 
Join Date: Feb 2005
Location: Groton NY
Posts: 32,286
Fix the exhaust crack first.
__________________
Old Cat Rider
'93 Wildcat 700EFI
w/ Comet 108 Pro-4 clutch & 01 ZR skid

'90 Wildcat Project in progress.

Vintage (sorta)
1980 Indy Trail 440 (for sale)
1980 AC Pantera (donor engine to the 90 wildcat)


http://www.dcdrifters.net/


Worshipful Master; F&AM Dryden Lodge# 472
http://www.masonicdryden472.org/

Rules of this forum are strictly enforced!
RJ Gleason is offline   Reply With Quote
Old 02-04-2013, 06:26 AM   #3 (permalink)
Registered User
 
ARCHER97's Avatar
 
Join Date: Nov 2011
Location: Milan, Mi
Posts: 223
Re: 86 excel issues

Thanks for the reply. Ill have to see if I can patch it when I get home.
__________________
'80 Yamaha 440 Exciter

'79 Yamaha 340 Enticer with
'78 txl 340 motor and a '80s
Indy skid.

'95 Polaris XCR 600

'86 Yamaha excel IIIU
ARCHER97 is offline   Reply With Quote
Old 02-04-2013, 07:01 PM   #4 (permalink)
Super Moderator
 
kccats's Avatar
 
Join Date: Dec 2006
Location: Northern IL
Posts: 19,645
Lotsa things! Yes fix the exh! Turn down the oil untill you use a qt of oil for every 12.5 gal of gas! then check that the motor is square to the driven! And then start with a new belt!
kccats is offline   Reply With Quote
Old 02-04-2013, 07:53 PM   #5 (permalink)
Registered User
 
ARCHER97's Avatar
 
Join Date: Nov 2011
Location: Milan, Mi
Posts: 223
Re: 86 excel issues

Thanks guys, it was the exhaust. I guess it was more than just a crack. I don't have a welder so I took a piece of sheet metal and four heavy duty pipe clamps and clamped it all together.

Eventually I'll get it welded but we just got 4 more inches of snow and we wanna ride
__________________
'80 Yamaha 440 Exciter

'79 Yamaha 340 Enticer with
'78 txl 340 motor and a '80s
Indy skid.

'95 Polaris XCR 600

'86 Yamaha excel IIIU
ARCHER97 is offline   Reply With Quote
Old 02-04-2013, 07:54 PM   #6 (permalink)
Registered User
 
ARCHER97's Avatar
 
Join Date: Nov 2011
Location: Milan, Mi
Posts: 223
Re: 86 excel issues

Here's what it looks like. It held up pretty good!
Attached Images
File Type: jpg uploadfromtaptalk1360029264239.jpg (104.0 KB, 17 views)
__________________
'80 Yamaha 440 Exciter

'79 Yamaha 340 Enticer with
'78 txl 340 motor and a '80s
Indy skid.

'95 Polaris XCR 600

'86 Yamaha excel IIIU
ARCHER97 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 12:08 AM.



Copyright SnowmobileForum.com

Search Engine Friendly URLs by vBSEO 3.6.0