no lights - Snowmobile Forum: Your #1 Snowmobile Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 01-14-2013, 07:34 PM Thread Starter
Registered User
 
Join Date: Jan 2013
Location: vermont
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
no lights

i put a new polaris voltage regulator on and it still blows bulbs so im kinda outa ideas other than cleaning up the conection and i want to ride at night any help would be appreciated thanx
polaris xc700 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 01-15-2013, 06:07 AM
Super Moderator
 
RJ Gleason's Avatar
 
Join Date: Feb 2005
Location: Groton NY
Posts: 33,298
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Check for shorts in the harness, particularly where the wires pass over the exhaust to the head light.

Old Cat Rider
'93 Wildcat 700EFI
w/ Comet 108 Pro-4 clutch & 01 ZR skid

http://www.dcdrifters.net/

Worshipful Master; F&AM Dryden Lodge# 472
http://www.masonicdryden472.org/

Rules of this forum are strictly enforced!
RJ Gleason is offline  
post #3 of 7 (permalink) Old 01-15-2013, 06:12 AM
I am Spartacus
 
smallengineguy's Avatar
 
Join Date: Feb 2004
Location: Milton Mills, NH
Posts: 23,801
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Measure the voltage coming out of the regulator. Is it 12-14VDC?

1992 Ski Doo Mach 1 (SC-10/2 suspended) March '07 SF.com Sled of the Month! (Lost in fire 4-7-13)
1992 Ski Doo Mach 1 original
2006 Ski Doo MXZ 500SS
1999 Ski Doo MXZ600
Webmaster Evergreen Valley Snowmobile Club
SledNH.com Moderator
smallengineguy is offline  
post #4 of 7 (permalink) Old 01-15-2013, 09:38 AM
Registered User
 
Join Date: Dec 2011
Location: Ennismore,Ontario, Canada
Posts: 32
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
is it both your headlights and tail light?
Skidoo shredder is offline  
post #5 of 7 (permalink) Old 01-15-2013, 10:13 AM
Registered User
 
scrammy650's Avatar
 
Join Date: Dec 2010
Location: newyork
Posts: 1,057
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
also check wires under seat sometimes they can fray and u wouldnt see it under there
scrammy650 is offline  
post #6 of 7 (permalink) Old 01-18-2013, 06:46 PM
Registered User
 
Join Date: Jan 2009
Location: Allagash Me
Posts: 47
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Grounds
trev70 is offline  
post #7 of 7 (permalink) Old 01-19-2013, 09:03 AM
Super Moderator
 
kccats's Avatar
 
Join Date: Dec 2006
Location: Northern IL
Posts: 21,168
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 26 Post(s)
Is the regulator grounded itself?
kccats is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Snowmobile Forum: Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome