no lights - Snowmobile Forum: Your #1 Snowmobile Forum
http://www.snowmobileforum.com
Go Back   Snowmobile Forum: Your #1 Snowmobile Forum > General Discussion Forums > General Sled Chat


» Sponsors





Reply
 
LinkBack Thread Tools Display Modes
Old 01-14-2013, 07:34 PM   #1 (permalink)
Registered User
 
Join Date: Jan 2013
Location: vermont
Posts: 2
no lights

i put a new polaris voltage regulator on and it still blows bulbs so im kinda outa ideas other than cleaning up the conection and i want to ride at night any help would be appreciated thanx
polaris xc700 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-15-2013, 06:07 AM   #2 (permalink)
Super Moderator
 
RJ Gleason's Avatar
 
Join Date: Feb 2005
Location: Groton NY
Posts: 31,864
Check for shorts in the harness, particularly where the wires pass over the exhaust to the head light.
__________________
Old Cat Rider
'93 Wildcat 700EFI
w/ Comet 108 Pro-4 clutch & 01 ZR skid

'90 Wildcat Project in progress.

Vintage (sorta)
1980 Indy Trail 440 (for sale)
1980 AC Pantera (donor engine to the 90 wildcat)


http://www.dcdrifters.net/


Worshipful Master; F&AM Dryden Lodge# 472
http://www.masonicdryden472.org/

Rules of this forum are strictly enforced!
RJ Gleason is offline   Reply With Quote
Old 01-15-2013, 06:12 AM   #3 (permalink)
I am Spartacus
 
smallengineguy's Avatar
 
Join Date: Feb 2004
Location: Milton Mills, NH
Posts: 23,646
Measure the voltage coming out of the regulator. Is it 12-14VDC?
__________________
1992 Ski Doo Mach 1 (SC-10/2 suspended) March '07 SF.com Sled of the Month! (Lost in fire 4-7-13)
1992 Ski Doo Mach 1 original
2006 Ski Doo MXZ 500SS
1999 Ski Doo Grand Touring
1998 Ski Doo Grand Touring
Webmaster Evergreen Valley Snowmobile Club
SledNH.com Moderator
smallengineguy is offline   Reply With Quote
Old 01-15-2013, 09:38 AM   #4 (permalink)
Registered User
 
Join Date: Dec 2011
Location: Ennismore,Ontario, Canada
Posts: 32
is it both your headlights and tail light?
Skidoo shredder is offline   Reply With Quote
Old 01-15-2013, 10:13 AM   #5 (permalink)
Registered User
 
scrammy650's Avatar
 
Join Date: Dec 2010
Location: newyork
Posts: 1,057
also check wires under seat sometimes they can fray and u wouldnt see it under there
scrammy650 is offline   Reply With Quote
Old 01-18-2013, 06:46 PM   #6 (permalink)
Registered User
 
Join Date: Jan 2009
Location: Allagash Me
Posts: 45
Grounds
trev70 is offline   Reply With Quote
Old 01-19-2013, 09:03 AM   #7 (permalink)
Super Moderator
 
kccats's Avatar
 
Join Date: Dec 2006
Location: Northern IL
Posts: 19,157
Is the regulator grounded itself?
kccats is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 01:12 PM.



Copyright SnowmobileForum.com

Search Engine Friendly URLs by vBSEO 3.6.0