need some help!!! - Snowmobile Forum: Your #1 Snowmobile Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 01-11-2013, 06:02 PM Thread Starter
Registered User
 
Join Date: Jan 2013
Location: maine
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
need some help!!!

I was just out riding my sled today. I got a 94 skidoo formula z 583. Everytime I went up a steep hill it seemed Luke the sled was losing power. It would pretty much come to a slow crawl even though you were on the throttle. It also started to overheat to as this was happening. Any suggestions. I have no clue what it could be.
kylemc1987 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 01-11-2013, 06:15 PM
Registered User
 
Join Date: Jan 2013
Location: muskoka
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Have you cleaned the carbs, clutches, checked all fluids including antifreeze, if so have you checked to see if your water pump is working?
mmsrx is offline  
post #3 of 6 (permalink) Old 01-12-2013, 10:21 AM Thread Starter
Registered User
 
Join Date: Jan 2013
Location: maine
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I hacent cleaned the carbs yet. Clutch looks alrigh. AlAll the fluids are roped off. I'll have to check the water pump tooo. Thanks for the advice Much needed. What's a sled if it can't climb hills.
kylemc1987 is offline  
post #4 of 6 (permalink) Old 01-12-2013, 04:51 PM
Registered User
 
Join Date: Jan 2013
Location: muskoka
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
mabey your thermostat is starting to stick
mmsrx is offline  
post #5 of 6 (permalink) Old 01-12-2013, 05:40 PM
Super Moderator
 
RJ Gleason's Avatar
 
Join Date: Feb 2005
Location: Groton NY
Posts: 33,163
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Do the sharpie test.

Old Cat Rider
'93 Wildcat 700EFI
w/ Comet 108 Pro-4 clutch & 01 ZR skid

http://www.dcdrifters.net/

Worshipful Master; F&AM Dryden Lodge# 472
http://www.masonicdryden472.org/

Rules of this forum are strictly enforced!
RJ Gleason is offline  
post #6 of 6 (permalink) Old 01-12-2013, 05:44 PM Thread Starter
Registered User
 
Join Date: Jan 2013
Location: maine
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
This might be a stupid question but what's the sharpie test.
kylemc1987 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Snowmobile Forum: Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome