Polaris belt problem - Snowmobile Forum: Your #1 Snowmobile Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 12-27-2012, 11:27 PM Thread Starter
Registered User
 
Join Date: Dec 2012
Location: Buffalo NY
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Polaris belt problem

Just a quick question

Today while i was riding, I went through 2 belts. My snowmobile has been vibrating a lot also. Is this because of a bad motor mount or do I just need the clutch to be aligned?
Polaris2006 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 12-27-2012, 11:33 PM
Super Moderator
 
BC_Dan's Avatar
 
Join Date: Jan 2004
Location: oregon
Posts: 13,475
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)
What sled? I'm betting 06 900... if so, definitely check motor mounts and alignment and use the 1115 belt instead of the 080.

Welcome to the forum!

2007 Dragon RMK 700 155", 2008 RMK 600 155", 95 Prowler 550 2-up, Really OLD AC Cheetah

http://www.avalanche.org/accidents.php
BC_Dan is offline  
post #3 of 3 (permalink) Old 12-27-2012, 11:37 PM Thread Starter
Registered User
 
Join Date: Dec 2012
Location: Buffalo NY
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
06 700! close though! And alright I will definitely do that, thank you
Polaris2006 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile Forum: Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome