1998 Ski-Doo MXZ 583 - Snowmobile Forum: Your #1 Snowmobile Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 12-22-2008, 03:58 AM Thread Starter
Registered User
 
Fifty54Four's Avatar
 
Join Date: Oct 2007
Location: Maine
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
1998 Ski-Doo MXZ 583

Hey guys,

So up here in Maine, were going through a heavy Blizzard. Seeing as how it looks like Winter is here to stay this time, I yanked my sleds out of my trailer and tried starting them up.

After several attempts, my Ski-Doo just won't start. Here are some of the symptoms.

- The Primer Pump leaks gasoline when you pull it out, and is extremely hard to push back in
- It appears that there is no gas going into the fuel lines. It all looks dry.
- When we pull the starter, no matter how many times, it doesn't even sound like the engine is catching.

My original idea was that there was water in the fuel lines, and it froze when it got cold, blocking the gas from moving through any of the lines.

Anyone got any other ideas of what it could be? And possible ideas on how to fix it?

Thanks in advance,

54

98 Ski-Doo MZX 583
Brap.
Fifty54Four is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 12-22-2008, 06:23 AM
I am Spartacus
 
smallengineguy's Avatar
 
Join Date: Feb 2004
Location: Milton Mills, NH
Posts: 23,759
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Replace the primer first. Squirt some 2 stroke mix into the carbs from a Windex bottle, that should get it fired up.

1992 Ski Doo Mach 1 (SC-10/2 suspended) March '07 SF.com Sled of the Month! (Lost in fire 4-7-13)
1992 Ski Doo Mach 1 original
2006 Ski Doo MXZ 500SS
1999 Ski Doo MXZ600
Webmaster Evergreen Valley Snowmobile Club
SledNH.com Moderator
smallengineguy is offline  
post #3 of 4 (permalink) Old 12-22-2008, 08:25 AM Thread Starter
Registered User
 
Fifty54Four's Avatar
 
Join Date: Oct 2007
Location: Maine
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
It sounds like a plan SEG, but the only thing is it doesn't seem that the Plunger for the Primer is broken at all. I mean, how could it break from sitting in my trailer all summer?

98 Ski-Doo MZX 583
Brap.
Fifty54Four is offline  
post #4 of 4 (permalink) Old 12-22-2008, 11:24 AM Thread Starter
Registered User
 
Fifty54Four's Avatar
 
Join Date: Oct 2007
Location: Maine
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I got it going. Put starter fluid in the carbs and it cranked right up. Thanks SEG.

98 Ski-Doo MZX 583
Brap.
Fifty54Four is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Snowmobile Forum: Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome