sled problem need help - Snowmobile Forum: Your #1 Snowmobile Forum
http://www.snowmobileforum.com
Go Back   Snowmobile Forum: Your #1 Snowmobile Forum > Snowmobile Tech / Mod Center > Engine / Drivetrain


» Sponsors





Reply
 
LinkBack Thread Tools Display Modes
Old 09-26-2006, 08:18 PM   #1 (permalink)
superman
 
loky's Avatar
 
Join Date: Sep 2006
Location: michigan
Posts: 4
Post sled problem need help

hey everyone i have a 91 skidoo xtc fourmal Mach 1 600 and well i want down the trail last year and my sled died and know the recoil is tight it wont let me start it or anythang Any idea what would cause this? thanks
loky is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-26-2006, 08:21 PM   #2 (permalink)
Registered Snow-Offender
 
I_R_Josh's Avatar
 
Join Date: Jan 2006
Location: Alaska
Posts: 1,054
any oil in the reservoir?
__________________
Ride Hard...complain later
I_R_Josh is offline   Reply With Quote
Old 09-26-2006, 08:26 PM   #3 (permalink)
superman
 
loky's Avatar
 
Join Date: Sep 2006
Location: michigan
Posts: 4
yup.......

Last edited by loky; 09-26-2006 at 08:45 PM.
loky is offline   Reply With Quote
Old 09-26-2006, 08:50 PM   #4 (permalink)
I am Spartacus
 
smallengineguy's Avatar
 
Join Date: Feb 2004
Location: Milton Mills, NH
Posts: 23,683
Remove the belt and see if you can turn the engine with the clutch. If not, you seized the motor up. Time to take it apart and see what seized.
__________________
1992 Ski Doo Mach 1 (SC-10/2 suspended) March '07 SF.com Sled of the Month! (Lost in fire 4-7-13)
1992 Ski Doo Mach 1 original
2006 Ski Doo MXZ 500SS
1999 Ski Doo Grand Touring
1998 Ski Doo Grand Touring
Webmaster Evergreen Valley Snowmobile Club
SledNH.com Moderator
smallengineguy is offline   Reply With Quote
Old 09-26-2006, 09:00 PM   #5 (permalink)
superman
 
loky's Avatar
 
Join Date: Sep 2006
Location: michigan
Posts: 4
naw its not seized its just tight it wont let me try to start it ?
loky is offline   Reply With Quote
Old 09-26-2006, 09:52 PM   #6 (permalink)
POLARIS RULZ
 
Wild child's Avatar
 
Join Date: Jan 2005
Location: Osage,Ia
Posts: 323
Quote:
Originally Posted by loky
naw its not seized its just tight it wont let me try to start it ?


It could be you're rings broke. It happened to a friend of mine he tried to start his sled and it was hard to pull over so we took it apart and he had broke a ring which was wedged in the cylinder
__________________
2005 Polaris Switchback 600ves
1998 Polaris XC600
Wild child is offline   Reply With Quote
Old 09-27-2006, 08:18 AM   #7 (permalink)
King of the Universe
 
IndianRvrShiver's Avatar
 
Join Date: Jan 2005
Location: Rochester Hizzle, MI
Posts: 6,678
Pull the exhaust off & look into the cylinder.....might see something amiss there!
__________________
********************
2003 AC F5 (Jr's Dec 07 SOTM & 2008 SOTY)
2003 AC F7 EFI SP (April 06 SOTM)
********************


"It's a public access forum, you post stupidity, expect to get flamed." - RJ Gleason
IndianRvrShiver is offline   Reply With Quote
Old 09-27-2006, 09:01 AM   #8 (permalink)
Registered User
 
eric phazer's Avatar
 
Join Date: Jul 2006
Location: Grand Valley, Ontario
Posts: 144
does the recoild click in or anything or is mabee the recoil just screwed.
eric phazer is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 11:43 AM.



Copyright SnowmobileForum.com

Search Engine Friendly URLs by vBSEO 3.6.0