580 ext efi,TPS - Snowmobile Forum: Your #1 Snowmobile Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 01-16-2013, 06:58 PM Thread Starter
Registered User
 
Join Date: Dec 2010
Location: Saskatchewan,Canada
Posts: 132
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
580 ext efi,TPS

I have a question and i think i know but i am just making sure.MY sled works great and pulls like a mother at all parts of the throttle except wide open.When it hits wide open it sometimes falls on its face and if you let of and stab it again its fine.Im guessing that the tps may be the culprit but i was just wanting some confirmation.And also i think my fuel mileage but be getting bad.
leearchibald is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 01-17-2013, 06:46 AM
Super Moderator
 
kccats's Avatar
 
Join Date: Dec 2006
Location: Northern IL
Posts: 21,231
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 27 Post(s)
NO! Not the TPS! Get a T and hose and gauge and do a fuel presure test! Also clean the clutches!
kccats is offline  
post #3 of 8 (permalink) Old 01-17-2013, 08:33 AM
Grudman
 
Grudman's Avatar
 
Join Date: Dec 2010
Location: ILL
Posts: 683
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Check the fule pressure and check your new springs you put in your clutches.

1997 Arctic Cat 580 Efi Deluxe

Grudman
Grudman is offline  
post #4 of 8 (permalink) Old 01-17-2013, 09:20 AM Thread Starter
Registered User
 
Join Date: Dec 2010
Location: Saskatchewan,Canada
Posts: 132
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I have a t in the line already with a gauge but its digital and its dead but when it was working a few weeks ago the gauge was reading 36 psi and sometimes if i jump it when i land it will do it and all i have to do is blip the throttle and its fine again
leearchibald is offline  
post #5 of 8 (permalink) Old 01-17-2013, 09:31 AM
Registered User
 
Join Date: Feb 2009
Location: Oconto Falls, WI
Posts: 230
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I'm dealing with the same thing sort of. What kind of mileage are you getting?
I have a drop in power at WOT and then if i let off and get back on it it pulls great again. I've blown up two pipes so far from to much fuel being dumped at top end. I will be doing some TPS adjustments on it this weekend but unfortunately no snow here after the rains last week so it will have to wait to test it out.
If you figure something out PM me and i will do the same if this works out.
Good luck.
ZRNUT is offline  
post #6 of 8 (permalink) Old 01-17-2013, 12:11 PM Thread Starter
Registered User
 
Join Date: Dec 2010
Location: Saskatchewan,Canada
Posts: 132
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
funny you mention that because i have blown a chunk out of my pipe as well.
leearchibald is offline  
post #7 of 8 (permalink) Old 01-18-2013, 06:59 PM Thread Starter
Registered User
 
Join Date: Dec 2010
Location: Saskatchewan,Canada
Posts: 132
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: 580 ext efi,TPS

So i put a new guage in my fuel line and its 36psi like it should be and im in the middle of a ride right now just stopping a freinds house and i while im riding i can actually make it do this bog on comand now,wide open across the feild no bog and if i blip the throttle a couple of times real quik i can make it bog and sometimes it does it on its own.

Sent from my HTC One S using Snowmobile.com App
leearchibald is offline  
post #8 of 8 (permalink) Old 01-20-2013, 12:39 PM Thread Starter
Registered User
 
Join Date: Dec 2010
Location: Saskatchewan,Canada
Posts: 132
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
bump
leearchibald is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile Forum: Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome