looking for help - Snowmobile Forum: Your #1 Snowmobile Forum
http://www.snowmobileforum.com
Go Back   Snowmobile Forum: Your #1 Snowmobile Forum > Specific Snowmobile Forums > Arctic Cat Snowmobiles


» Sponsors





Reply
 
LinkBack Thread Tools Display Modes
Old 12-30-2012, 02:15 PM   #1 (permalink)
Registered User
 
Join Date: Dec 2012
Location: minnesota
Posts: 1
looking for help

I have a 99 zr600 efi cat. yesterday it started to bog and backfire
and then it killed. I figured it was bad fuel so I siphoned out the
old fuel and put it new with some isopropyl to handle any possible
moisture and then checked the plugs, they are fine. I ran the sled
today and the same thing occured. I hadread that it may be the tss/kill switch so i unplugged that and ran itand the same thing is still happening. the sled will start and idle just fine but once i hit the throttle it will run
bog and backfire. any ideas what i should look at next, any help would
be appreciated.
prayforsnow is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-30-2012, 02:39 PM   #2 (permalink)
Registered User
 
tmikula54871's Avatar
 
Join Date: Jan 2008
Location: N.W. Wisconsin
Posts: 61
I have a 98 ZR600 EFI and it sounds like it may be your stator. I've had lots of problems with mine. You can test it with a multimeter pretty easily. Look in the sticky threads at the top of the Artic Cat forum page to find out how to test it. Good luck!
__________________
Current Sleds
'98 Ski-doo Formula 500 Deluxe
'94 Jag 440Z

Sleds of the past
2 '90 Cougars
'94 ZR440
'96 EXT 580
'98 ZR600 EFI
tmikula54871 is offline   Reply With Quote
Old 12-31-2012, 07:18 AM   #3 (permalink)
Registered User
 
Blaine1's Avatar
 
Join Date: Sep 2009
Location: Flushing, MI
Posts: 704
Sounds like stator. Here is how to test the ohms on it:

__________________
Wanted: Dead Stators PM me.

Testing Cat triple stators
http://www.youtube.com/watch?v=Uzz2NZiw3fk

Stator Testing ZR/ZL 1998-1999 500 & 600 Carburated
http://www.youtube.com/watch?v=XM3m9i6uqSw

Stator Testing ZR/ZL 1998-1999 500 & 600 EFI
http://www.youtube.com/watch?v=jbxhExP-2P0

Stator Testing Early 1990's 700 & 580 EFI with the triangular 3 prong connector
http://www.youtube.com/watch?v=jbxhExP-2P0

Jumper wire bypass
http://www.youtube.com/watch?v=GPpzQL8J9ik
Blaine1 is offline   Reply With Quote
Old 01-01-2013, 07:44 PM   #4 (permalink)
Super Moderator
 
kccats's Avatar
 
Join Date: Dec 2006
Location: Northern IL
Posts: 19,384
How about fuel pump and fuel presure?
kccats is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 09:06 PM.



Copyright SnowmobileForum.com

Search Engine Friendly URLs by vBSEO 3.6.0