95 580 ext efi - Snowmobile Forum: Your #1 Snowmobile Forum
http://www.snowmobileforum.com
Go Back   Snowmobile Forum: Your #1 Snowmobile Forum > Specific Snowmobile Forums > Arctic Cat Snowmobiles


» Sponsors





Reply
 
LinkBack Thread Tools Display Modes
Old 12-08-2012, 07:17 PM   #1 (permalink)
Registered User
 
Join Date: Dec 2010
Location: Saskatchewan,Canada
Posts: 132
95 580 ext efi

my temp light started to come on and then ficker off and on after about 50miles of my first ride of the season,exchangers are warm not hot and i can hold my hand on the motor not for long but i can hold it there.Shut the sled off adn let it cool down started and the light still was on,let it sit for a week and started it light was off but came on after you rode it around for awhile but nothing is hot,and the coolant is up and there no coolant coming out of my pee hole so i know the pump is fine.
leearchibald is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-08-2012, 07:28 PM   #2 (permalink)
Grudman
 
Grudman's Avatar
 
Join Date: Dec 2010
Location: ILL
Posts: 606
could be bad temp sensor.It is old you know !
__________________
1997 Arctic Cat 580 Efi Deluxe

Grudman
Grudman is offline   Reply With Quote
Old 12-09-2012, 05:46 AM   #3 (permalink)
Registered User
 
Blaine1's Avatar
 
Join Date: Sep 2009
Location: Flushing, MI
Posts: 701
Get a lser temp gun and see how hot the motor actually is. Might be a bad sensor, might be a thermostat partially sticking at times...ect...best thing to put on any sled is a water temp gauge.
__________________
Wanted: Dead Stators PM me.

Testing Cat triple stators
http://www.youtube.com/watch?v=Uzz2NZiw3fk

Stator Testing ZR/ZL 1998-1999 500 & 600 Carburated
http://www.youtube.com/watch?v=XM3m9i6uqSw

Stator Testing ZR/ZL 1998-1999 500 & 600 EFI
http://www.youtube.com/watch?v=jbxhExP-2P0

Stator Testing Early 1990's 700 & 580 EFI with the triangular 3 prong connector
http://www.youtube.com/watch?v=jbxhExP-2P0

Jumper wire bypass
http://www.youtube.com/watch?v=GPpzQL8J9ik
Blaine1 is offline   Reply With Quote
Old 12-09-2012, 06:06 AM   #4 (permalink)
Super Moderator
 
kccats's Avatar
 
Join Date: Dec 2006
Location: Northern IL
Posts: 19,152
Id say pull the therm and atleast heat it on the stove with a thermomitor and see when it opens and how far!
kccats is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 04:37 AM.



Copyright SnowmobileForum.com

Search Engine Friendly URLs by vBSEO 3.6.0