95 580 ext efi - Snowmobile Forum: Your #1 Snowmobile Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 12-08-2012, 07:17 PM Thread Starter
Registered User
 
Join Date: Dec 2010
Location: Saskatchewan,Canada
Posts: 132
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
95 580 ext efi

my temp light started to come on and then ficker off and on after about 50miles of my first ride of the season,exchangers are warm not hot and i can hold my hand on the motor not for long but i can hold it there.Shut the sled off adn let it cool down started and the light still was on,let it sit for a week and started it light was off but came on after you rode it around for awhile but nothing is hot,and the coolant is up and there no coolant coming out of my pee hole so i know the pump is fine.
leearchibald is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 12-08-2012, 07:28 PM
Grudman
 
Grudman's Avatar
 
Join Date: Dec 2010
Location: ILL
Posts: 683
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
could be bad temp sensor.It is old you know !

1997 Arctic Cat 580 Efi Deluxe

Grudman
Grudman is offline  
post #3 of 4 (permalink) Old 12-09-2012, 05:46 AM
Registered User
 
Blaine1's Avatar
 
Join Date: Sep 2009
Location: Flushing, MI
Posts: 706
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Get a lser temp gun and see how hot the motor actually is. Might be a bad sensor, might be a thermostat partially sticking at times...ect...best thing to put on any sled is a water temp gauge.

Wanted: Dead Stators PM me.

Testing Cat triple stators
http://www.youtube.com/watch?v=Uzz2NZiw3fk

Stator Testing ZR/ZL 1998-1999 500 & 600 Carburated
http://www.youtube.com/watch?v=XM3m9i6uqSw

Stator Testing ZR/ZL 1998-1999 500 & 600 EFI
http://www.youtube.com/watch?v=jbxhExP-2P0

Stator Testing Early 1990's 700 & 580 EFI with the triangular 3 prong connector
http://www.youtube.com/watch?v=jbxhExP-2P0

Jumper wire bypass
http://www.youtube.com/watch?v=GPpzQL8J9ik
Blaine1 is offline  
post #4 of 4 (permalink) Old 12-09-2012, 06:06 AM
Super Moderator
 
kccats's Avatar
 
Join Date: Dec 2006
Location: Northern IL
Posts: 21,180
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 26 Post(s)
Id say pull the therm and atleast heat it on the stove with a thermomitor and see when it opens and how far!
kccats is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile Forum: Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome