03 ZL 600 Lacks top end speed - Snowmobile Forum: Your #1 Snowmobile Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 12-15-2011, 08:22 PM Thread Starter
Registered User
 
Join Date: Dec 2011
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
03 ZL 600 Lacks top end speed

2003 ZL 600 EFI goes 0-50 mph no problem but will not accelerate pass that or if it does it takes for ever. Any ideas what the problem is?
peterson85 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 12-15-2011, 08:56 PM
Super Moderator
 
kccats's Avatar
 
Join Date: Dec 2006
Location: Northern IL
Posts: 21,227
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 27 Post(s)
Apv!
kccats is offline  
post #3 of 4 (permalink) Old 12-15-2011, 09:02 PM Thread Starter
Registered User
 
Join Date: Dec 2011
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
cleaned them already and the servo is working
peterson85 is offline  
post #4 of 4 (permalink) Old 12-17-2011, 07:32 PM
Registered User
 
DnD800's Avatar
 
Join Date: Sep 2004
Location: NH
Posts: 710
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by peterson85 View Post
cleaned them already and the servo is working
I'm not doubting you but how do you know the servo is working? Are the cables set properly? Another issue I have heard although not on that model is the baffle/shield coming loose inside the silencer causing it to loose power.
DnD800 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile Forum: Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome