thumb warmer not working - Snowmobile Forum: Your #1 Snowmobile Forum
http://www.snowmobileforum.com
Go Back   Snowmobile Forum: Your #1 Snowmobile Forum > Specific Snowmobile Forums > Arctic Cat Snowmobiles


» Sponsors





Reply
 
LinkBack Thread Tools Display Modes
Old 12-19-2008, 05:57 AM   #1 (permalink)
Registered User
 
Join Date: Oct 2008
Posts: 12
thumb warmer not working

I have a 1998 ZL 500,and the thumb warmer does not work,and the hand warmers are only luke warm,any suggestions.Thanks GROD
grod is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-19-2008, 06:22 AM   #2 (permalink)
I am Spartacus
 
smallengineguy's Avatar
 
Join Date: Feb 2004
Location: Milton Mills, NH
Posts: 23,658
Are the lights bright? If so, it may be a connection problem. Check the voltage at the warmer plug.
__________________
1992 Ski Doo Mach 1 (SC-10/2 suspended) March '07 SF.com Sled of the Month! (Lost in fire 4-7-13)
1992 Ski Doo Mach 1 original
2006 Ski Doo MXZ 500SS
1999 Ski Doo Grand Touring
1998 Ski Doo Grand Touring
Webmaster Evergreen Valley Snowmobile Club
SledNH.com Moderator
smallengineguy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 12:10 PM.



Copyright SnowmobileForum.com

Search Engine Friendly URLs by vBSEO 3.6.0