Speedometer Problems - Snowmobile Forum: Your #1 Snowmobile Forum
http://www.snowmobileforum.com
Go Back   Snowmobile Forum: Your #1 Snowmobile Forum > Specific Snowmobile Forums > Arctic Cat Snowmobiles


» Sponsors





Reply
 
LinkBack Thread Tools Display Modes
Old 12-19-2007, 04:41 PM   #1 (permalink)
Registered User
 
Arctic_Cat_Wins's Avatar
 
Join Date: Jan 2007
Posts: 4
Speedometer Problems

I have a 98 500zl it runs great other then the fact that my speedometer stopped workin at the end of last year it is still gettin power so i dont kno if something has just been unscrewed. Any suggestions would be greatly appreciated.
Arctic_Cat_Wins is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-19-2007, 05:37 PM   #2 (permalink)
I am Spartacus
 
smallengineguy's Avatar
 
Join Date: Feb 2004
Location: Milton Mills, NH
Posts: 23,682
http://www.snowmobileforum.com/engin...se-things.html
__________________
1992 Ski Doo Mach 1 (SC-10/2 suspended) March '07 SF.com Sled of the Month! (Lost in fire 4-7-13)
1992 Ski Doo Mach 1 original
2006 Ski Doo MXZ 500SS
1999 Ski Doo Grand Touring
1998 Ski Doo Grand Touring
Webmaster Evergreen Valley Snowmobile Club
SledNH.com Moderator
smallengineguy is offline   Reply With Quote
Old 12-19-2007, 06:10 PM   #3 (permalink)
Super Moderator
 
kccats's Avatar
 
Join Date: Dec 2006
Location: Northern IL
Posts: 19,639
The drive bearing is bad!
kccats is offline   Reply With Quote
Old 12-19-2007, 08:40 PM   #4 (permalink)
Registered User
 
DFickel's Avatar
 
Join Date: Nov 2007
Posts: 227
I had a rare case where my cable got damaged which in turn backed up into the drive adapter. I was lucky it wasn't the bearing, but unless your cable is bad or something, be prepared to do some work.
__________________
FDRAGONS, TUNNIN FORKS, AND BEES CANT KILL THEM CATS!
DFickel is offline   Reply With Quote
Old 12-20-2007, 07:57 PM   #5 (permalink)
Registered User
 
Join Date: Nov 2007
Posts: 20
You say your speedo is getting power. I assume you mean the cable is turning at the point where the cable screws to the speedo guage. If that is the case, then your speedo guage is probably bad. If the cable is not turning at the guage, then it is probably a bad cable or bad drive bearing.
2delimit is offline   Reply With Quote
Old 12-20-2007, 08:05 PM   #6 (permalink)
Registered User
 
Arctic_Cat_Wins's Avatar
 
Join Date: Jan 2007
Posts: 4
i mean that the speedometer lights up still but it doesnt work my tacometer both lights up and works tho
Arctic_Cat_Wins is offline   Reply With Quote
Old 12-20-2007, 11:36 PM   #7 (permalink)
Super Moderator
 
BC_Dan's Avatar
 
Join Date: Jan 2004
Location: oregon
Posts: 12,520
The speedometer is a cable driven instrument, driven mechanically by a cable that goes from the PTO end of the driveline to the speedometer. Read the thread SmallEngineGuy suggests for some ideas. The tachometer works by sensing the impulses of the stator, so it runs by electricity.
__________________
2007 Dragon RMK 700 155", 2008 RMK 600 155", 95 Prowler 550 2-up, Really OLD AC Cheetah

http://www.avalanche.org/accidents.php
BC_Dan is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 08:30 AM.



Copyright SnowmobileForum.com

Search Engine Friendly URLs by vBSEO 3.6.0